All Things WinBatch > WebBatch

InitInstance Error

(1/2) > >>

JTaylor:
I've started getting the following in a project I'm working on.  Nothing shows in the ErrorLog...I assume because it never gets to a point it can write an error.   Can't find anything in the Help File or TechDatabase.  What causes such an error?

Jim


--- Code: HTML5 ---<H1>WebBatch Error</H1>
<Pre>
Batch DLL initialization error

Err num 37
</Pre>
<HR>
Content-type: text/html

<H1>WebBatch Error</H1>
<Pre>
WebBatch Error

InitInstance failed
</Pre>
<HR>

 

JTaylor:
I also get this instead sometimes.


--- Code: HTML5 ---
<H1>WebBatch Error</H1>
<Pre>
WebBatch Error

InitApplication failed
</Pre>
<HR>

 

JTaylor:
A bit more info.  I am making about 30 requests very close to each other.  Wouldn't think that would overpower WebBatch though.

Jim

td:
As the error log implies, the WIL interpreter DLL or WebBatch main process is failing during early initialization.  The error number tells us were it is failing ( in a Win32 API call) but not why.  If WebBatch sometimes works on your system, the best guess on the cause is a  race condition in the OS's Win32 API.    If WebBatch always fails with this error even in low demand situations then your system is sick. 

Assuming that the cause is a race condition, you may want to examine your Web server's configuration settings for something that would address CGI instance startup or some other CGI related setting that might address the problem.

JTaylor:
I have been running WebBatch for years on this server with no problem.  Nothing has changed recently except I upgraded WebBatch, apart from, perhaps, Windows Updates.

Jim

Navigation

[0] Message Index

[#] Next page

Go to full version