All Things WinBatch > Customer Service

WinBAtch and Win7

(1/2) > >>

cfann:
I just installed WinBatch on Windows7.  Everything seemed the same as on XP until I tried to compile a second time.  The first time was fine, but get this on second try....

Compiler Error - Unable to create(then it gives the path).  The file may be in use, or marked read only or the specified output directory may not exist.

NONE of these are true.  I'm compiling the same as I did on XP.

I can create a new directory to save it in and it works...but I CAN NOT do that each time I need to recompile!

Please help!

td:
Please indicate the version of WinBatch+Compiler you are using and the UAC settings on your Windows 7 machine.  Also does the error message show the file name of the exe or the .cmp file?

cfann:
WinBatch 2004F and WBC 2004F dll(5.4fed)

It displays the .exe

Thanks!

cfann:
UAC setting is default

td:
It could be some kind of permission issue related to UAC and  folder or file security, or it could have something to do with any anti malware software taht might be on the system. 

I suppose you could try temporarily turning off  UAC to see if that fixes the problem.  That would at least give you some idea of the cause and suggest some possible workarounds.  You may also want to check the file (both .exe and .cmp) and folder permissions to make sure you have Read, Write, and Modify access.

 So much has changed in both Windows and WinBatch in the last 12+ years that any suggestions are little more than somewhat educated guesses.       

Navigation

[0] Message Index

[#] Next page

Go to full version