viewpoint-particle

Author Topic: Process Extender Fails to Load on Server 2012  (Read 1470 times)

Trippinout

  • Newbie
  • *
  • Posts: 8
Process Extender Fails to Load on Server 2012
« on: July 22, 2016, 05:55:44 am »
Does anyone have an idea why the process extender would fail to load on Server 2012R2.

Error:
AddExtender("WWPRC44I.DLL")
(2062) VALUE INT => 0
WIL ERROR SUPPRESSED =>1437 (AddExtender: Extender DLL load failed)

07/22/16  08:48:42  WBT - WInCollectRemove64.exe
WIL Extender load error
Extender DLL is invalid.

I have Winbatch version 2013a and using process extender version 44016

The issue only seems to happen on Server 2012.

Thanks

td

  • Tech Support
  • *****
  • Posts: 2814
    • WinBatch
Re: Process Extender Fails to Load on Server 2012
« Reply #1 on: July 22, 2016, 07:07:59 am »
First we need dispel the idea that this has something to do with your Windows version.  The extender works just fine on any version of Windows starting with Window 2000 and continuing through Windows 10 and Windows 2012 R2.  That easy enough to verify.

The most common cause of error 1437 is attempting to load the 32-bit extender into 64-bit WinBatch.   The Process Extender does not have 64-bit version so it can only be used with 32-bit WinBatch.
"No one who sees a peregrine falcon fly can ever forget the beauty and thrill of that flight."
  - Dr. Tom Cade

Trippinout

  • Newbie
  • *
  • Posts: 8
Re: Process Extender Fails to Load on Server 2012
« Reply #2 on: July 22, 2016, 07:39:21 am »
That explains it. Thanks.

The reason I didn't see it, was the TerminateApp function that is used before the Process extender is working on 64Bit win7 so I was not seeing the error.