viewpoint-particle

Author Topic: set a property stops winbatch and winbatch_if  (Read 2049 times)

Didier

  • Newbie
  • *
  • Posts: 2
set a property stops winbatch and winbatch_if
« on: November 12, 2013, 11:53:48 am »

any attempt to update a property dd.language prompt a window in 7. No error in winbatch but the program stops. no way to have an error.
winbatch ceased to work. the properties are not read only.  It is the same phenomenon with the other properties I am aware of.

oBAPICtrl = CreateObject("SAP.BAPI.1")
oLogonCtrl = CreateObject("SAP.Logoncontrol.1")
tt=oLogonCtrl.NewConnection()

; tt is a dispatch dixit the wil type viewer
; language is a bstr dixit wil type viewer

tt.language="FR" ;  creates an error
oBAPICtrl.Connection = tt
dd= oBAPICtrl.Connection
ss=ObjectType("BSTR","k3pe1.de.kaercher.com")
truc=dd.language
dd.language=truc    ; will create the error
ff=dd.whateverdoesnexist   ; will fail method not recognised

do you any clue what it should be?
this kind of code have worked during the last 10 years.


Didier

Deana

  • Wilson WindowWare Tech Support
  • Pundit
  • *****
  • Posts: 1183
  • WinBatch® can do it.
    • WinBatch Tech Support Database
Re: set a property stops winbatch and winbatch_if
« Reply #1 on: November 12, 2013, 01:54:31 pm »
Please add DebugTrace(@on,"trace.txt") to the beginning of the script, run it until the error or completion, then post the trace file here ( removing any private info).

You mention that this has worked for 10 years. What has changed exactly? Did you move it to Windows 7 and now it errors? Has it ever successfully ran on Windows 7?
Deana F.
Technical Support
Wilson WindowWare Inc.

Didier

  • Newbie
  • *
  • Posts: 2
Re: set a property stops winbatch and winbatch_if
« Reply #2 on: November 12, 2013, 05:44:49 pm »
The change is imho a switch to windows  7 (32).
I use the uac settings that works for MS automation see extension _if and the appropriate developement exe.
I will retest from xp and set trace on in 5 hours and report. The issue is always when setting the property.
It never runs on 7.
Thanks for the hint.
Didier