(off topic) Why can't I run a file from a network drive?

Started by snowsnowsnow, April 04, 2024, 08:41:44 PM

Previous topic - Next topic


(I'm back - been off WB for a long time now - but still dabble in it)

This is OT, but I've often asked general Windows questions here in the past and gotten good answers (better than I get from any of the usual online help places).

Another Win7 thingie.  Say I have a network drive (which is actually a Samba location on a Linux machine) mapped to, say, W: in Windows.  I have a file on there called, say, foobar.jpg.  I can read, copy, or delete that file from Windows - no problem.  But I cannot run it.  I would like to run it and have it come up in whatever photo viewer is the default.

When I run it (directly from the CMD prompt), I get "Access denied" (also if I run it from a WB script via any of the Run*() functions).  If I copy it to a local drive and run that, it of course works as expected.  Why is this and is there a workaround?


Not sure if it is the issue in your case but Windows 7 was notorious for a buggy SMB protocol implementation.
"No one who sees a peregrine falcon fly can ever forget the beauty and thrill of that flight."
  - Dr. Tom Cade