All Things WinBatch > WebBatch

New Install: Stones app submits fail

(1/4) > >>

I installed WebBatch 2012 on IIS 7 using the instructions in the help file
I can start the stones.web page and it looks normal
When I click Take Stones, the WebBatch license page is displayed instead of the stones page
Any idea on what I need to configure?

Enter your WebBatch license information? You should have either a temporary or purchased license that is sent to you by email.

It already is licensed.  It says this copy of WebBatch is licensed to...

This may be due to the WebCGI user not having been added to Local Security Policy\Local Policies\User Rights Assignment:
    Adjust memory quotas for a process
    Create a token object

I'll have an admin add the user to those items in group policy for the server and we'll see what happens.

I have a version of Windows 2012 R2 running IIS 8.5 displayed on my other monitor as I type and the stones games works just fine.  Same is also true for Windows 2012 and IIS 8.0 I tried a bit ago.  Neither required adjustments to the IIS_IUSER privileges as set by default. 

Generally, if the stones game is working your installation is correct.  When you click on a the Take Stones button all you are doing is running the stones.web file again with a parameter.   The link that runs stones.web is on about line 14 of the stones.web file and should look something like the following:

--- Code: Winbatch ---WebOut('<FORM ACTION="/webcgi/webbatch.exe?stones/stones.web+%stones%" METHOD=POST>',1)
You might want to take a peek at it.  Someone or something may fiddled with the file.  Also note that calling WebBatch.exe without a script as a parameter will cause the WebBatch version (license) page to appear.


[0] Message Index

[#] Next page

Go to full version