WinBatch Technical Support Forum

Archived Boards => COM Automation and dotNet => Topic started by: stanl on June 07, 2015, 11:33:24 am

Title: Strange error
Post by: stanl on June 07, 2015, 11:33:24 am
Just refreshing using ISAM drivers with either the Jet or ACE Providers, in the snippet below, the URL is valid and the ISAM is installed, but the error is Internet Login Failure, which doesn't make a lot of sense:
Code: Winbatch
cConn='Provider=Microsoft.ACE.OLEDB.12.0;Data Source=http://www.bennetyee.org/ucsd-pages/area.html;Extended Properties="HTML Import;HDR=YES;IMEX=1";'
;cConn='Provider=Microsoft.Jet.OLEDB.4.0;Data Source=http://www.bennetyee.org/ucsd-pages/area.html;Extended Properties="HTML Import;HDR=YES;IMEX=1";'
oConn=CreateObject("ADODB.Connection")
oConn.ConnectionTimeOut=0
oConn.CommandTimeOut=0
oConn.CursorLocation=3
oConn.Open(cConn)

oRS=CreateObject("ADODB.Recordset")
oRS.Open("select count(*) from [Area Code Listing, by Number]", oConn, 2,1,1)
oRS.Save(dirscript():"htmltest.xml",1)
oRS.Close()
oRS=0
oConn.Close()
oConn=0

Exit

 
Title: Re: Strange error
Post by: JTaylor on June 07, 2015, 02:44:59 pm
Not that it helps but I see the same behavior.  I tried several different things but with no luck.  All I can find on the web is references to using this approach for HTML data created from an Excel or Access file.

Jim
Title: Re: Strange error
Post by: stanl on June 07, 2015, 05:10:27 pm
You see, I commented out the Jet 4.0 connection, but I remember it working with Jet. Probably been deprecated like SOAP was by Microsoft.