Author Topic: Postie Extender doesnt work and vcheck problem  (Read 220 times)

pweyrosta

  • Newbie
  • *
  • Posts: 6
Postie Extender doesnt work and vcheck problem
« on: January 04, 2020, 09:12:00 am »
I tried the example script to send an email and the response-code is always "Could not connect to server <FQDN>:25, error -1"
Since the extender is probably older than the winbatch version I'm using (2019b) I tried to run vcheck to download the newest version of the postie extender.
But this fails with en error message saying:

This setup program has detected an expired Winbatch+Compiler maintenance plan which does not cover the version of this extender that you are installing....

and fails to install even though I do have a valid maintenance plan until december, 2020.

I tried to connect to the same host using a telnet program to port 25 and I can send an email without any problem. So it's the extender that's not working correctly.
Any idea what to look after?

td

  • Tech Support
  • *****
  • Posts: 3464
    • WinBatch
Re: Postie Extender doesnt work and vcheck problem
« Reply #1 on: January 04, 2020, 10:06:17 am »
It is not the extender that is not working correctly. We use the extender on a daily basis.  It works just fine when used correctly.  You likely either have an incorrect parameter set in one of the extender's functions or a firewall setting is blocking the WinBatch executable from accessing one or more TCP ports. 

It is simple enough to test whether or not the current version of the Postie extender will install on a system with 2019b and a current license so we did and had no problems.  You may want to check that your license is indeed up to date.  The Postie extender does require a license issued in June or later of last year.  To check run WinBatch Navigator in the same exact environment you are running your Postie script.  Click on the  "License Info" button to see your license details. 
"No one who sees a peregrine falcon fly can ever forget the beauty and thrill of that flight."
  - Dr. Tom Cade

pweyrosta

  • Newbie
  • *
  • Posts: 6
Re: Postie Extender doesnt work and vcheck problem
« Reply #2 on: January 04, 2020, 12:32:57 pm »
Hi,

Thanks for the tip with the Winbatch Navigator.
My actual license keys were not registered with the system (always thought that is done automatically when compiler asks you for the keys...)
So I was able to install the latest postie extender and now I'm able to send emails as well.

Thanks a lot for your help!

best
Peter